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Using Flash Video MX 

Flash Video MX is an encoding application that lets you encode video in Macromedia Flash Video (FLV) and SWF formats. The 
FLV format lets you easily incorporate video into a web page or Flash document in a format that almost anyone can view using the 
Flash Player. The ubiquity of Flash Player ensures that most visitors to your website can view Flash Video without downloading 
additional plug-ins, so you can reach the largest possible Internet viewing audience with low development, testing, and support 
costs.

 

 

 

 

This chapter contains the following topics:

Supported video compression codecs for Flash Video

Understanding video standards and terminology

Encoding video with Flash Video MX Batch Encoder

Selecting advanced video encoding settings

 

 

 



Supported video compression codecs for Flash Video

By default, Flash Video MX encodes video using  the Sorenson H.263 codec for use with Flash Player 7 and the On2 VP6 codec  
for use with Flash Player 8. To understand how Flash achieves high-quality video with low bandwidth requirements, you should 
understand video compression. 

There are two types of compression that can be applied to digital media: spatial and temporal. Spatial compression is applied to a 
single frame of data, independent of any surrounding frames. Spatial compression can be lossless (in which no data is discarded 
from the image) or lossy (in which data is selectively discarded). A spatially compressed frame is often called an intraframe.

Temporal compression identifies the differences between frames and stores only those differences, so that frames are described 
based on their difference from the preceding frame. Unchanged areas are simply repeated from the previous frame(s). A temporally 
compressed frame is often called an interframe.

Both the On2 VP6 and Sorenson H.263 are interframe codecs. Although many other codecs use intraframe compression (for 
example, JPEG is an intraframe codec), the efficient interframe compression of the On2 VP6 and Sorenson H.263 codecs, among 
other features, distinguishes them from other compression technologies because these codecs require a much lower data rate (also 
known as the bit rate) to produce high-quality video.

It’s important to note that interframe codecs also use intraframes. Intraframes are used as the reference frames (keyframes) for the 
interframes. Both the On2 VP6 and Sorenson H.263 codecs always begin with a keyframe. Each keyframe becomes the main 
reference frame for the following interframes. Whenever the next frame is significantly different from the previous frame, the codec 
compresses a new keyframe.

 

 

 

 

 

 

 



Understanding video standards and terminology

The following section introduces digital video concepts and terminology you should know when working with video content. If you 
are new to digital video or want to learn more about digital video and encoding high-quality video content, this section can help you 
understand the trade-offs related to encoding video for different applications and Internet viewing environments.

 

 

 

 

 

 

 

 

 

 

 

 

 



Encoding video with Flash Video MX Batch Encoder

By default, Flash Video MX Batch Encoder encodes source videos using the Sorenson H.263 codec to encode video for Flash 
Player 7. The Flash Video MX Batch Encoder uses the On2 VP6 codec, which is compatible with Flash Player 8 .

When configuring encoding settings, you can select individual files and specify different settings based on the type of video format 
and quality required for each file, or you can select multiple files and specify the same settings for all of them.

To encode video with the Flash Video MX Batch Encoder:

1.  Start Flash Video MX Batch Encoder by selecting Start > All Programs > Flash Video MX>Flash Video MX Batch Encoder, or 
open the folder that contains the Flash Video MX Batch Encoder application,and double click the application icon . 

2.  In the Flash Video MX Batch Encoder, add source video clips to the list of files to encode. You can drag a file into the list, or 
click the Add button and select a file on your computer. 
TIP  You can select multiple video files and drag them into the list of files to encode.

3.  Click Settings (Edit > Encoding Settings) to display the Flash Video MX Batch Encoder Encoding Settings dialog box. 

For information on advanced video encoding settings, see Specifying advanced video encoding settings.
4.  Verify that the encoding profile you’ve selected is appropriate for your intended application. The text box below the Flash 

Video Encoding Profile pop-up menu displays the Flash Player version, video codec, video bit rate, and audio encoding 
information for the selected encoding profile. 

5.  Enter a file name for the encoded FLV file. If you don’t specify a filename, Flash Video MX Batch Encoder uses the filename 
of the source video clip. When naming a file, do not enter the .flv extension; Flash Video MX Batch Encoder does this 
automatically. 

You can specify a destination folder in which to save the encoded FLV file relative to the folder containing the source video 
clip. When specifying a destination folder:

❍     The destination folder you specify must already exist. If you specify a folder that doesn’t exist, an error message 
informs you that the file cannot be encoded because the folder cannot be found. 

❍     Or you can create a flolder in which to save encoded files by click output floder . 
6.  Do one of the following: 

❍     Click Show Advanced Settings to further adjust the encoding settings, or to modify the video clip’s size or playback 
length using the crop and trim controls. 

❍     Click OK to close the Flash Video MX Batch Encoder Encoding Settings dialog box. 
7.  Click Start Queue to begin encoding your files. 

Flash Video MX Batch Encoder starts encoding the first file in the video encoding list. While a file is being encoded, the 
Status column of the video encoding list provides information on the status of each video:

Waiting indicates that the file is in the encoding queue but has not been encoded. You can remove a file from the queue that 
has not been encoded or that is not being encoded. For more information, see Removing files from the encoding queue.

Skip indicates that the file will be skipped during the encoding process. You can choose to skip files or change their status to 
Waiting. For more information, see Skipping a file.

If there is no waiting task in the encoding queue, you must change the task status by click Edit>Reset Status.

  



 

 

 

 



Specifying advanced video encoding settings

The advanced video and audio settings let you select the quality of your FLV files. The Encoding tab is divided into two categories: 
Video settings lets you specify the encoding options for video files; Encode Audio lets you select the bit rate for MP3 audio 
encoding. The following sections describe the encoding options.

To specify custom video encoding settings:

1.  Select the file or files whose encoding settings you want to modify. 

To select multiple files in the encoding list, Control-click (Windows), or select File > Select All to select all files in the encoding 
queue.



2.  Click Settings (Edit > Encoding Settings). 

The Flash Video Encoding Settings dialog box appears.

3.  Click Advanced Settings. 
4.  The Advanced Flash Video Encoding Options are displayed. 
5.  Select a video codec with which to encode your content from the Video Codec pop-up menu. 

If you are authoring for Flash Player 7, select Sorenson H.263 codec; if you are authoring for Flash Player 8, select On2 VP6 
codec.

6.  Select a frame rate. Flash Video MX Batch Encoder uses t 12 fps as the source video by default. If you need to alter the 
frame rate, be sure you understand how modifying the frame rate affects the video quality. For more information, see 
Understanding video standards and terminology. 

CAUTION  If you are modifying the encoding settings for a video clip that will be embedded within a SWF file, the video 
frame rate must match that of the SWF file. 

7.  Select the frame rate placement for the video. 
❍     Specify the quality setting for the video from the Quality pop-up menu. The quality setting determines the data rate of 

the encoded video. The higher the data rate, the better the quality of the encoded video clip. 
■     Select a preset Quality setting (Low, Medium, or High) to automatically select a Data Rate value. When you 

select Low, Medium, and High from this menu, the Maximum Data Rate text box value is updated to reflect the 
specified value. 

■     Select Custom and enter a value, in Kilobits/Sec, in the Maximum Data Rate text box. 
NOTE  If you find that the preset quality settings do not work with your source footage, try specifying a custom 

maximum data rate. For more information on data rate, and how it affects video quality, see Data rates. 

❍     Resize the video clip: 
1.  Select the Resize video check box. 
2.  Specify values for Width and Height. You can specify a frame size in pixels or as a percentage of the original 

image size. 
NOTE  If you resize a video clip’s frame size, and do not select the Maintain Aspect Ratio checkbox, the video may 

become distorted.
❍     Select the Video fade check box and Set the fade in and fade out duration, and the fade color. 
❍     When you finish specifying advanced encoding settings, you may select  the Video Misc tab to add a custom image 

logo and text on the video, or select SWF tab to add video effect and playback control panel for SWF, or just click OK 
to return to the main Flash Video MX Encoding dialog box. 

If you are ready to encode your video clips, or need to add additional source video clips to encode, see Encoding video 
with Flash Video MX Batch Encoder.

To learn about the other options available in the Flash Video MX Batch Encoding Settings dialog box, see the following 
sections:

●     Specifying advanced audio encoding settings 
●     Specifying video effects and Flash playback control panel 
●     Specifying your video LOGO and Caption 

 



Data rates

The data rate affects the quality of a video clip and the audience that can download the file given their bandwidth constraints.

When you deliver video using the Internet, you should produce files using lower data rates. Users with fast Internet connections can 
view the files with little or no delay, but dial-up users must wait for files to download. If you anticipate an audience of dial-up users, 
you should make short video clips to keep the download times within acceptable limits.

Flash Video MX lets you specify data rate settings for encoding video at a low, medium, or high quality. If the available settings in 
the Quality pop-up menu do not produce the desired results with your particular source footage, select Custom, and enter a higher 
data rate in the Maximum Data Rate text box. 

 

 

 

 

 

 

 

 

 

 



Specifying advanced audio encoding settings

The Encode Audio area of the Flash Video MX Batch Encoding Settings dialog box is automatically enabled when you click 
Settings.

To specify custom audio encoding settings:

1.  Select the file or files whose encoding settings you want to modify. 

To select multiple files in the encoding list, Control-click (Windows) , or select File > Select All to select all files in the 
encoding queue.



2.  Click Settings (Edit > Encoding Settings). 

The Flash Video Encoding Settings dialog box appears.

3.  Click Advanced Settings. 
4.  The Advanced Flash Video Encoding Options are displayed. 
5.  The Encode Audio checkbox is selected by default. By default, the audio codec is MP3. 
6.  Select a Sample rate from the Sample Rate combo box, and select a Bit rate .
7.  You can set the fade in and fade out effect,and set the fade in and fade out duration. 
8.  Select  the audio channel type from the Audio Channel combo box, default is stereo. 

To learn about the other options available in the Flash Video MX Encoding Settings dialog box, see the following sections:

❍     Specifying advanced video encoding settings 
❍     Specifying advanced effects settings and Flash playback control buttons 
❍     Specify encoding settings your video LOGO and Caption 

 

 

 

 

 

 



Specifying video effect and Flash playback control panel

The SWF Misc tab allows you to select  a Video control bar and Flash effect for the output flash file.

Control Bar Style: Click to select a style for your playback control bar in the Select a video control bar combo box. 

Video Effect: You can add some animation effects such as snow, flower, leaf etc. to you video. Click “Flash effect” drop-down list 
and select the effect you prefer. We will release more effects on our website from time to time. You can always visit our website to 
update your video effects for free.

To learn about the other options available in the Flash Video MX Batch Encoding Settings dialog box, see the following sections:



●     Specifying advanced video encoding settings 
●     Specifying advanced audio encoding settings 
●     Specifying video LOGO and Caption 

 

 

 

 

 

 



Specifying your video LOGO and Caption

LOGO: Choose to add a LOGO to your video. Click the Browse button to select your LOGO image from your hard disc and select 
an alignment for it. You can set the absolute position and the size of LOGO.

 (Note: Once you've set the absolute position and size for the logo, do not change the alignment combo box, because it will change 
the absolute position and size)  

Transparent: After selecting an image from your hard disc as your logo, you can select the "Select..." item in the Transparent 
combo box to set a transparent color for the logo.

(TIP: A transparent color is a color that do not draw to your video. It is always used to remove the logo image's background)

User Caption: Choose to add caption to your video. Type the caption text you want to add and select an alignment for it.You can 
set the absolute position of Caption. 



To learn about the other options available in the Flash Video MX Batch Encoding Settings dialog box, see the following sections:

●     Specifying advanced video encoding settings 
●     Specifying advanced audio encoding settings 
●     Specifying video effect and Flash playback control panel 

 

 

 

 

 

 



Removing files from the encoding queue

You can remove any video from the encoding queue before it is encoded. 

To remove a video from the encoding queue:

1.  Select the video (or videos) that you want to remove from the source file list. 
2.  Click Remove(edit>Remove). 

 

 

 

 

 

 

 

 

 

 

 



Skipping a file

You can specify that Flash Video MX Batch Encoder not encode a file in the current encoding queue. 

To skip a file:

1.  Select the file or files that you want to skip in the encoding queue. To select multiple files in the encoding queue, Control-click 
(Windows) . 

2.  Select Edit > Skip Selection. 

To stop encoding a file:

●     Click the skip button which under the rate of progress. 

 

To reset a skipped file for encoding:

1.  Select the file or files in the encoding queue that you want to reset to the Waiting to Encode state. To select multiple files in 
the encoding queue, Control-click (Windows). 

2.  Select Edit > Reset Status. 

The selected file or files will be reset to the Waiting to Encode state. You can reset the status of files while Flash Video MX 
Batch Encoder is encoding.

 

 

 

 

 

 



Selecting advanced video encoding settings

The Advanced Setting options of Flash Video MX Batch Encoder let you create custom video encoding settings.

Before creating custom video encoding settings, be sure you understand the different video encoding options. For information about 
video encoding options, see Understanding video standards and terminology.

To specify advanced video encoding settings:

1.  Select the file or files whose encoding settings you want to modify. 

To select multiple files in the encoding list, Control-click (Windows) , or Edit > Select All to select all files in the encoding 
queue.

Click Settings (Edit > Encoding Settings). 

The Flash Video Encoding Settings dialog box appears.

2.  Click Advanced Settings. 

The Advanced Flash Video Encoding Options are displayed. This dialog box lets you perform the following actions:

❍     Specify alternate encoding settings to deliver video for different bandwidths and applications. 
❍     Trim the video clip to alter its dimensions as well as beginning and ending frames. 
❍     Add various video effects, including snow, lighting, fire and so forth. 
❍     Specify  video LOGO, caption. 

To learn about the options available in the Advanced Settings dialog box, see the following sections:

●     Specifying advanced video encoding settings 
●     Specifying advanced audio encoding settings 
●     Specifying video effects and Flash playback control panel 
●     Specifying your video LOGO and Caption 

 

 

 

 



About encoding video with non-square pixels

Most static computer graphics use square pixels, which have a width-to-height ratio of 1:1. When working with digital video, pixels 
often have a different width-to height ratio and are referred to as rectangular pixels. The reason for this behavior is to allow analog 
video (e.g. broadcast television) and digital video (e.g. DVD video) to coexist. When encoding video formats with non-square pixels 
(also known as anamorphic video), you need to resample the video image to the correct Display Aspect Ratio (DAR).

For example, standard NTSC digital video (DV), has a frame size of 720 x 480 pixels, and it’s usually displayed at an aspect ratio of 
4:3. This means that each pixel is rectangular, with a pixel aspect ratio (PAR) of 10:11 (a tall, narrow pixel). Both MPEG 1 and 2 
video are also produced in various sizes (720 x 480 or 480 x 480 are common) even though they are typically displayed with either 
a 4:3 or 16:9 (wide screen) aspect ratio.

To calculate the image frame size to use when encoding video using non-square pixels, you must first decide which dimension--
width or height--is the preferred master dimension, and then compute the other dimension as follows:

If height is the master dimension, calculate the width using the following formula:

  

For example, if your video uses an aspect ratio of 4:3 the equation would appear as: 

  

If width is the master dimension, calculate the height using the following formula:

  

For example, if your video uses an aspect ratio of 4:3 the equation would appear as:

  

As an example, if you are encoding a video whose frame size is 720 x 480 pixels, and you want to encode it with a 4:3 aspect ratio, 
you must determine the width at which to encode the video frame in pixels:

  

The result is a video image height of 640 pixels.

Thus, you need to encode the 720 x 480 image to 640 x 480, a standard 4:3 aspect ratio.

To correct the image size when encoding using Flash Video Encoder, deselect the Maintain Aspect Ratio check box in the 



Advanced Encoding Settings dialog box, and enter the corrected dimensions at which to encode the video. For more information, 
see Selecting advanced video encoding settings.

 

 

 

 

 



Aspect ratios (frame size)

Keyframes are complete video frames (or images) that are inserted at consistent intervals in a video clip. The frames between the 

As with the frame rate, the aspect ratio (or frame size) for your document is important for producing high-quality video. At a specific 
data rate (connection speed), increasing the frame size results in decreased video quality. When you select the frame size for your 
document, consider the frame rate, the aspect ratio of the source video clip, and your personal preferences to create a successful 
video presentation. Standard video display resolutions on the Internet include 640 x 480, 512 x 384, 320 x 240, and 160 x 120 
pixels.

The most common aspect ratio is 4:3 (standard television). Increasingly, 16:9 and 2:1 (wide screen) aspect ratios are becoming 
more commonplace as well. Typically, you should encode the video using the same aspect ratio at which it was originally captured. 
Altering a video clip’s aspect ratio may result in a distorted video image. An exception to this practice is when encoding digital video 
(DV) formats, whose aspect ratio is slightly different than the 4:3 aspect ratio because DV uses rectangular pixels. When encoding 
video content captured with a digital video camera, you must manually specify the frame size of the DV format you are using to 
preserve the video’s aspect ratio. For more information see, About encoding video with non-square pixels.

The following list of standard frame sizes can be used as a guideline. You can experiment to find the best setting for your project.

Frame sizes for 4:3 aspect ratio video:

●     Modem (56k): 160 x 120 
●     DSL: 320 x 240 
●     Cable: 512 x 384 
●     Cable/corporate LAN: 640 x 480 

Frame sizes for 19:16 aspect ratio video:

●     Modem (56k): 192 x 108 
●     DSL: 384 x 216 
●     Cable: 448 x 252 
●     Cable/corporate LAN: 704 x 396 

 

 

 



Comparing the On2 VP6 and Sorenson H.263 codec

 Using the On2 VP6 codec provides the following advantages when compared to the Sorenson H.263 codec:

●     Encodes higher quality video at the same data rate 
●     Supports the use of an alpha channel to create composite video 

In order to support better quality video at the same data rate, the On2 VP6 codec is noticeably slower to encode, and requires more 
processor power on the client computer to decode and play back the video data. For this reason, you should consider the lowest 
common denominator of computer that your audience will use when they access your Flash video content. 

If you anticipate a large user base that is using older computers, it may be advisable to consider encoding your FLV files using the 
Sorenson H.263 codec.

 

 

 

 

 

 

 

 

 



Frame rates

Video is a sequence of images that appear on the screen in rapid succession, giving the illusion of motion. The number of frames 
that appear every second is known as the frame rate, and it is measured in frames per second (fps). The higher the frame rate, the 
more frames per second are used to display the sequence of images, resulting in smoother motion. The trade-off for higher quality, 
however, is that higher frame rates require a larger amount of data to display the video, which uses more bandwidth.

When working with digitally compressed video in a format such as Flash Video, the higher the frame rate, the larger the file size. To 
reduce the file size, you must lower either the frame rate or the data rate (for more information, see Data rates). If you lower the 
data rate and leave the frame rate unchanged, the image quality is reduced. If you lower the frame rate and leave the data rate 
unchanged, the video motion may look less smooth than desired.

Because video looks much better at native frame rates (the frame rate at which the video was originally filmed), We recommends 
leaving the frame rate high if your delivery channels and playback platforms allow it. For full-motion NTSC, (the standard defined by 
the National Television System Committee in the U.S.), use 29.97 fps; for PAL (Phase Alternating Line, the dominant television 
standard in Europe), use 25 fps. If you lower the frame rate (which can significantly reduce the video data that must be encoded), 
Flash Video MX Batch Encoder drops frames at a linear rate to achieve the new fps rate. However, if you need to reduce the frame 
rate, the best results come from dividing evenly. For example, if your source has a frame rate of 24 fps, then reduce the frame rate 
to 12 fps, 8 fps, 6 fps, 4 fps, 3 fps, or 2 fps. If the source frame rate is 30 fps, in most cases you can adjust the frame rate to 15 fps, 
10 fps, 6 fps, and so on.

If your video clip is encoded with a higher data rate, a lower frame rate can improve playback on lower-end computers. For 
example, if you are compressing a talking-head clip with little motion, cutting the frame rate in half might save only 20 percent of the 
data rate. However, if you are compressing high-motion video, reducing the frame rate has a much greater effect on the data rate.

 

 

 

　 

 



Keyframes

Keyframes are complete video frames (or images) that are inserted at consistent intervals in a video clip. The frames between the 
keyframes contain information on movement and scene changes that occurs between keyframes. For example, if a video depicts a 
person walking past a doorway, the keyframes contain the complete image of the person and the door in the background, and the 
interval frames contain information describing the person’s movement as they walk in front of the door.

By default, Flash Video MX Batch Encoder automatically determines the keyframe interval to use based on the video clip’s frame 
rate. The keyframe interval value tells the encoder how often to re-evaluate the video image and record a full frame, or keyframe, 
into an FLV file. In Flash Video MX, this setting is the keyframe interval value, which represents the number of frames between 
keyframes. Flash Video MX approximates frames that reside between keyframes by estimating the full value of all pixels on the 
screen by comparing multiple frames and eliminating redundant information.

The keyframe interval value can be any number up to 100. When you select Automatic as an interval setting, Flash Video MX 
places a keyframe every two seconds of playback time. For example, if the video you’re encoding has a frame rate of 30 fps, a 
keyframe will be inserted every 60 frames. In general, the default keyframe interval value provides a reasonable level of control 
when seeking within a video clip. If you need to select a custom keyframe placement value, be aware that the smaller the keyframe 
interval, the larger the file size.

If your footage has a lot of scene changes or rapidly moving motion or animation, then the overall image quality may benefit from a 
lower keyframe interval. In general, a higher keyframe interval produces better image quality because data is not wasted describing 
the areas of an image that remain unchanged from frame to frame.

An important dependency of the keyframe interval is that it affects the ability of Flash Player to seek (fast-forward or rewind) through 
an FLV file. Flash Player can only advance from keyframe to keyframe, so if you want to skip to different places and pause the 
frames, you must use a lower keyframe interval value. If you want to advance to every frame in an FLV file, use a keyframe interval 
value of 1. When you reduce the keyframe interval value, you must raise the data rate for the Flash video to maintain comparable 
image quality.

 

 

 

 



Move up or down file in the encoding queue

You can move up or down any video in the encoding queue before it is encoded, so that you can easily encode the encoding file . 

To move up or  down a video from the encoding queue:

1.  Select the video that you want to move up or  down  in the source file list. 
2.  Click  move up or  move down (edit>move up or edit>move down). 

 

 

 

 

 

 

 

 

 

 

 

 



Saving the encoding queue

You can manually save the current encoding queue--including all encoding settings. If you do not choose to save the encoding 
queue, it is saved automatically when you exit Flash Video MX Batch Encoder.

To save the encoding queue:

●     Select File > Save Queue. 

 

 

 

 

 

 

 

 

 

 

 



About encoding audio-only files

The same considerations exist for audio production as for video production. To achieve good audio compression, you must begin 
an audio file that is free of distortion and audible artifacts introduced from the source recording. If you are encoding material from a 
CD, try to record the file using direct digital transfer rather than your sound card’s analog input. The sound card introduces an 
unnecessary digital-to-analog and analog-to-digital conversion that can create noise in your transferred audio. Direct digital transfer 
tools are available for both Windows and Macintosh platforms. If you must record from an analog source, use the highest quality 
sound card available.
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